Back to overview
Resolved

Opine application degraded

Jul 2, 2026 at 11:32am UTC
Affected services
app.tryopine.com

Resolved
Jul 2, 2026 at 11:32am UTC

Some users are experiencing slowness when loading the application. We're actively investigating the issue.

Update: Application performance is stable and the Opine team continues to monitor.